Any way to force custom resolution in Mini Metro?


#1

Just bought Mini Metro and it’s lovely, but my low spec Surface 3 Pro gets quite hot while playing at the maximum resolution. However none of the lower resolution options are 3:2 aspect ratio and I lose a part of the screen which is quite annoying.

Is there any way to force a custom resolution such as 1500x1000? Also would it be possible to disable anti-aliasing then altogether to get rid of the blurriness (yes yes jagged eges, but I think it would look better without aa) or is this done through Windows?

I have no trouble digging through some config files, but I couldn’t find anything this time.

Thanks in advance!
Eemil


#2

Hi, sorry to hear that you are having resolution troubles.

We do have support for custom resolutions, but not through the in-game options. If you are playing through Steam, then you can right click on Mini Metro in your Library and select Properties. From there, select Set Launch Options.

The commands that you are going to want to enter are “-width x -height y”, where x and y are the resolution that you want to play in. This will force the game resolution to be the size you want it to be!

Also note that this alone will force the game into windowed mode, and editing the resolution options in-game again will cause it to go back to our defaults. You can force the game into fullscreen by adding the launch command of “-fullscreen 1”, however if the resolution you set isn’t a native resolution supported by your monitor, then it will again revert to a supported resolution.

Also, there is no way to disable the smoothing in game. Hopefully this doesn’t impede your experience too much.

Hope these instructions are clear enough. Feel free to message if you have any further troubles.

~ Tom


#3

Unfortunately I’m not running the game through Steam. Could these commands be used with the standalone version?

Eemil


#4

I tinkered around with those commands a bit and got them working on the standalone version by launching the game from a batch file or command prompt. I found out that the problem with the resolution lies within Windows, since apparently it has only one supported 3:2 resolution. It seems to be possible to add more supported resolutions, but I figured out that it just isn’t worth it anymore.

For now I’ll just enjoy the game as it is since this resolution thing is just a small annoyance.
Thanks for the help and quick replies! Keep up the good work!
Eemil


#5

Ah yes! Was going to add that you can just add them as command line parameters too - but you got there yourself!
I’m glad you’ve sorted it out, and hope you enjoy playing.
~ Tom