Cities locked after new version update


I updated my Mini Metro version on ios (with 2016-12-25 new one)
new cities are locked (Seoul & Shangai) but also all other from Berlin (wich were unlocked in previous version I played with)
I connected with facebook profile so I thought my history plays is saved
Thanks for your help/answer - Happy new year


Let me get this clear again…

You have updated Mini Metro on iOS, and you thought your old saves will be intact after the update. But the update wiped out your save file, and now you have to replay the game to re-unlock the cities?

Can you give iOS version, what type of iPhone, and check to see if your high scores are in there or not?


Erk, that’s not supposed to happen! Just to clarify, you said it was on iOS but also that you connected with Facebook, but the Facebook login is only on desktop. Do you mean this happened on desktop?

On iOS even if the local profile is wiped (if you deleted the game, for instance), as long as you’ve been signed in to Game Center the game will pull down your achievements which will unlock the cities. The profile is also synced to iCloud by default. If you restart the app again, has it still not unlocked the previous cities?

On desktop if you’re signed in to a service that stores achievements (Steam or GOG) then it’ll also pull down those achievements if the profile is wiped. Steam also syncs the profile to Steam Cloud.


Hi Thanks. My IOS is El Capitan on mac-computer. I tried to delete MiniMetro (v14) and to reinstall it : no issue with v14 but same problem with v15.
Furthermore with this last version, when I start to play (NY city) after a few minutes play doesn’t give me locomotive and means any more.


It happened to me too, downloading Gamma 15 after playing with Gamma 12 for some time. I’m on Windows 10. I think there might have been a problem in the folders created in C:/Users/Username/AppData/LocalLow

A second Mini Metro folder (instead of “MiniMetro” without a space) appeared when I started playing Gamma 15, which never happened before. If I copied the savegame file from the previous folder, I managed to get my progress and high scores back.


Gah, ok. Thanks for letting me know. gamma15 did indeed switch the app’s name from ‘MiniMetro’ to ‘Mini Metro’, with a corresponding change in where Unity stores the persistent data, but we made sure the game checked both folders. I’ll have to check why it didn’t work in the wild.


If you need any other information, please don’t hesitate!


Unfortunately in the office it’s all working as expected. :expressionless: Could you please temporarily rename your localProfile.json in the new folder so it can’t find it, start Mini Metro, and send me the log file? It details where it looks for the legacy profile so it should be fairly clear what’s going wrong.


Ok that sounds like some other entirely new bug! Could you please send me ( the log if that behaviour happens again?


Peter, I have just sent you the log file, thank you!


Please let me know when your issue is resolved.