Daily Challenge isn't showing my score :(


#1

Hi

After finishing the daily challenge, if I’m not in the top ten, my placing isn’t displayed
Not a big deal, but it’s kinda taken some enjoyment away for me

I’ve had this issue for several weeks on both my iPads (iOS 10.3.3 and 9.3.5) If I found the version of the app correctly, this is it… 201804241649

I’ve tried removing the app from both devices, and also have signed out of Game Centre

Any help would be sweet

Cheers
Vinny :slight_smile:


#2

Oh dear, sorry for the trouble! What map was this on?


#3

Something definitely fishy about the daily challenge for the past week. It’s been telling me every single day that I’ve already played, and I see some random score that I’ve supposedly posted. It’s Auckland Extreme today, 4 hours into the day, and there’s already 10 people with 2000+ scores, including myself… I’d say that’s near impossible in auckland extreme.

Is this an issue with google play? Can anything be done?


#4

Esh! Every single day? That’s the worst I’ve heard of it. Thank you for sending this info our way. I’ll send this off to the team and see what we can do about it.


#5

Yes every day. Something changed today – I was able to play Sao Paulo.

If this helps any with the trouble shooting: on the days that I’m told I’ve already played … I will see the “Compete” button, but then a moment later it turns into “Replay”. I’m wondering if a database on my own phone is somehow miscommunicating with the server?


#6

Cheers, thanks for the update. We’ve been keeping an eye on the issue for a bit and a couple of fixes were tried but didn’t seem to work. Something caused it to happen a bit more in the last while which is also strange.

We’re having a look into it now. It looks like there are a couple of things that could cause some troubles. We’re going to allot some time on it and hopefully have a solution for you.


#7

I don’t know if you found anything – but in the last few days I haven’t seen any of the problems that were coming up for me last week.

This problem vinny first described in this thread – I’ve had that too in the past, but in my experience it was because I had somehow disconnected myself from google games, and it took awhile of twiddling with connection settings and google play profiles before I could see the mini metro top scores again.


#8

FYI … for the first time since May, I was unable to Compete in today’s daily challenge. Seoul (July 4 in kiwi time). A false, and top high score had already been attributed to me.


#9

Thanks for the heads up (and apologies!). We’ve gotten some time to look at the problem and it seems like the Google Play leaderboards are causing some troubles. We’ve got the team looking at it and we’ll hopefully have a fix for it soon. Thanks for your patience with this.


#10

I’m wondering if those high scores are the seemingly outrageous 10,000 or greater scores that pop up from time to time


#11

Hi, just wondered if there was an update for my issue with the Daily Challenge not showing the rank of my score

Cheers

Vinny


#12

The problem is if the score is submitted but isn’t processed immediately by Game Center, when the leaderboard is updated your score isn’t present. In that case we take the game’s record of your local score and insert it into the leaderboard as best we can. We don’t pull down the entire leaderboard so we can only set the rank if you’re in the top 10. If you exit the game and restart you should get your rank.

Always when replying to these threads I realise some tiny optimisations. If the game fetches a leaderboard without finding the local score we should set a refresh timer on it. I’ll add it to the backlog. :slight_smile: