Full screen misalignement


#9

Fresh install of the game with no changes to ingame settings. The log is in the first post. I do not understand, which DPI settings are you talking about. Probably it is 100%.

I have Full HD screen + laptop (1366x768), so in total it is over Full HD. Laptop is the main screen. The game opens on it but is misaligned related to mouse and extends out of main screen. None goes to secondary screen. Looks like the screenshot by poebelkinder.


#10

If you’re playing in dual monitor setups, then I really don’t know. I never use any dual monitor setups, especially with a laptop, so I have no clue as to what’s causing the problem. Maybe it’s related to how the game maximizes the estate depending on your total resolution estate (Monitor 1 scaled + Monitor 2 scaled screen estate)?

DPI Setting is this shown below. Another term for this is Text Scaling Settings.


#11

Hej,

I switched the screens and it was possible for me to play it on the first of the two extra-screens. Its an VGA. The game has no problems to adjust to the rotated outlay of the screen.
I still have the problem on the other screen. The mouse is not working and it is missaligned.

Since it is working for one screen and i have two identical ones, it can’t be the scaling.

My System: Debian, XFCE with AWESOME Windowmanager. I manage my screens with xrandr in the terminal.

Max


#12

That would be a bug for Unity programs. You may have to file a bug over there at the Unity community.


#13

AWESOME Windowmanager Max is using has nothing to do with unity as far as I understand.

Just for information: I also reproduced the error on Ubuntu 14. And I can play on either screens, if I switch off the dual monitor.


#14

So, Unity can run games for dual monitors? Or it’s only isolated to this game?


#15

This is the first full screen application I have had a problem with. Sometimes flash things like Youtube fullscreen on a wrong screen but I guess it has nothing to do with that.


#16

I had problems in the past on the lab computers for Unity before, so I thought it was Unity’s fault.

Acknowledged.


#17

I can also use other games in fullscreenmode on my computer with the two screens.

Maybe its working for me in one screen, since i set up the launch option in steam: “-screen-fullscreen 0”

@Johu_Vapohu: can you give it a try?

MAx


#18

I tried the option on commandline. Did not change a thing. I did not run it through steam though. I don’t have steam. Bought it from Humble Bundle.


#19

If you bought it from Humble Bundle, maybe you can try registering the game into your Steam account, and then try the shortcut?


#20

I bought it via Humble Bundle too, but I installed Steam after it crashed via terminal.
I think, the option might only work in steam. But I’m not sure.

After I’ve set up the launch options, it’s working for me.

So I have no further clue.

Max


#21

I am also having problems playing this game fullscreen on linux with multiple monitors. Arch Linux with Gnome 3 desktop and 3 monitors.

The game starts on the correct screen at the correct resolution but the mouse is offset.


#22

Ack, that’s no good. Unity’s a pain with dual monitors—with the launcher you can select which monitor to use, but we hoped to do away with it to streamline the startup. Unity does have a command line parameter ‘-adapter N’, but that’s only useable on Windows for some reason. I’ll see what we can do for better monitor support.


#23

What platforms are people have difficulty with? I know Linux is problematic—are Windows and OS X also causing issues? We could ship just the Linux executable with the launcher, not ideal but at least it would fix the problem. :expressionless:


#24

This confirms my reasoning that it’s Unity’s problem in the first place, and not the developers.

Have you tried filing a report to Unity about dual monitors? They should have a whole bunch of discussions about this issue.


#25

The problem with sending a report to Unity is that it might get fixed, someday, but probably not in time for Mini Metro’s release.


#26

Yep, Unity’s fairly tardy with fixing non-critical issues. It drives me nuts that it’s the simple windowing stuff like this that they still have fairly immature support for. Fullscreen on OS X isn’t supported that well either, especially Retina resolutions.


#27

Sorry for the thread necro, but I just bought the game, tried running on Linux, wondered why the game was “unresponsive”, then pressed escape and noticed the offset… So this is still an ongoing problem.

Any command line arguments I could set in Steam so it runs within one specific screen? Or is the work around to disconnect that second display / run it in Windows ?


#28

Well, as you know, Unity’s Linux support is really absymal sometimes. I wouldn’t get your hopes up on that. Unless, things have changed…

If you’re still having an ongoing problem on Linux platforms, it’s very likely it’s Unity’s fault for not fixing them in a timely matter.

If you have screenshots, GIFs (via Gifcam), or something that we can see it happening in real-time, we can then deem what is wrong very quickly.