Game Crashes since last update Ubuntu Linux


#1

I have tried with 16.04, 15.10, and 14.04 all crash after the last update. Steam connects and as the game loads there is a black flash and the game closes
I went to look for logs and the place they should be is empty. I have also tried reverting back to previous nvidia driver even though I played the game earlier that day and had not updated. I also then updated the driver still same behaviour


#2

Are you able to locate the crash log files for each subsequent crashes? If yes, can you please upload the crash logs and attach it to your post, or copy/paste it to Pastebin/Hastebin? Follow the instructions in the stickied “Log File Locations” thread here.

Instructions
Pastebin
Hastebin


#3

https://hastebin.com/yusadugegu.pas

It worked up until the last update. I have nvidia 304.135 driver installed. tried reverting back to 134 but same thing


#4

What Nvidia graphics card model do you have? Driver 304.135 is considered really legacy at this point. I’m curious on why you’re not on 375.39.


#5

nvidia GeForce 7600 GS 375.39 is not appropriate for my card. It worked until the last minimetro update


#6

My guess is your Nvidia card is an AGP graphics card, which doesn’t support OpenGL 3.X and above.

I am not a developer, but I would find it weird the game doesn’t have a fallback for this.

Please wait for @peter or @shiprib to respond.


#7

No its not an AGP card and it does support OpenGL.

OpenGL extensions

https://hastebin.com/upejikufug.nginx


#8

I have another video card I might swap out to see if its hardware related although I am pretty sure thats not the problem


#9

Keep us in the loop. Thanks.


#10

Do you happen to have a log on-hand from the previous version? As far as I know the previous update was also built against Unity 5.3.5f1, so I don’t know what could have changed to cause a crash so early on. We did have one build a few updates ago on Unity 5.4.2 (I think?), which was the last version of Unity before they jacked up the Linux minimum spec to OpenGL 3 (PC & Mac were on 5.4.3 for that update). We’ve since had to downgrade back to 5.3.5f for an issue with the iOS build on 5.3.6+ (long story!)

We do have the last desktop build using Unity 4 on the snowleopard branch on Steam, could you try reverting to that temporarily and uploading the log?


#11

Ah, just saw the log said it was looking for an OpenGL 3.2 profile. I’ll do some digging tomorrow.


#12

I changed out the card to a 9600 GT and I also purged all Nvidia drivers. When I installed the proprietary drivers for this card it worked. So it was either the card or drivers (I have had to play with nvidia drivers in the past), but regardless…IT WORKS NOW!!!


#13

It would be either the game itself, or the card itself, if the drivers couldn’t resolve your issue.