Game no longer runs (it used to before)


#1

I can no longer run Mini Metro on my computer. I don’t understand why, because I could before. Now, whenever I try to start it, I get a brief popup that says the game is starting and… that’s it. Nothing else. It literally stops running. I’ve already updated my drivers, and that hasn’t helped. I tried switching off the Steam Overlay and that hasn’t helped. I tried running it in compatibility mode, and that did nothing. I can’t even get an output log from the thing! Even restarting didn’t help. All I can do right now is play the mobile version via BlueStacks, but that’s a bit sluggish for me, and it feels… off. I’m getting desperate! What do I have to do to get the game running again?


#2

Ack, sounds like it must have been one of the Unity updates we’ve done on the engine. If it’s not even starting enough to get a log it’ll be something low-level. The easiest way to check that will be to switch to either of the ‘snowleopard’ or ‘opengl2’ branches on Steam. They are the last builds we made before switching away from Unity 4 (for ‘snowleopard’) and whichever version of Unity was the last to ship with the Linux OpenGL 2.x renderer.


#3

The opengl2 branch still works on my machine. Maybe it doesn’t meet the requirements of Unity 4.