Google Play Not working


I downloaded this game yesterday and wanted to connect Google Play to see Rankings. I can press the button, then it starts a loading animation that never stops. If I tap outside, a screen appears where I can select my Google Play account, but after selection there’s just a never ending loading animation. I can upload pictures if necessary.


When this happens to me, I close the minimetro app and restart it. The scores usually display properly after that, and minimetro remembers whatever score I had before I stopped it. Sometimes Google Play still doesn’t cooperate, and I try this sequence again later, or the next day.


I’ve been trying for 3 days to connect Google play, it never works for me. I tried your fix with restarting the app, but it didn’t help


I’ve seen other comments like you’ve made here, about not being able to connect to google play. I don’t know much about the link between google play, and mini metro, other than the loading animation issue happens often for me. Especially after finishing daily challenge. Occasionally, I’ve manually disconnected from google play in “MiniMetro Options”, restarted, then reconnected… it might make a difference.


I can’t disconnect it because I’m not able to connect it at all, but this might help someone else. I think I’ll email them because it’s really annoying me at the moment