Metro refuses to pickup any passengers at one specific station


I have also had this issue. If you pick up and re-place the train, it’s brain gets reset and will again start picking up passengers.


Well, in this case it was neither a busy station, nor did picking up and re-placing the train (tried some times before failing due to crowding) do any good. And it didn’t clear itself after a few trains went through.


I have had this problem as well. On the attached screenshot, see the circle junction station near the right-hand side (with the ‘jumpy’ passenger), and see the double green train moving south from it? This empty train just went through the station and totally failed to pick up any of the passengers waiting there. It usually happens several times in a row with different-coloured trains all of which could have picked up. Makes me frustrated cos it seems to break the basic ‘pact’ between game and player, that the train will pick up passengers if it can/should.


I also have the same problem on OS X (Beta13). I just played Cairo and had a loop with all of the shapes, yet, none of the locomotives picked up


[Updated 2] Visual issue with multiple tracks crossing the same station. Not bug nor feature

Daniel: I hope you’re talking about the station on the island, because the other station on the red line that’s overcrowding isn’t even hooked up to your system. Cheers!


Oh funny! I didn’t notice that one, but yes, the one on the island was getting skipped as well.


I have encountered the same bug several times. This is a screenshot of my last game, already lost and continued in scenic. Notice all the triangle passengers at the cross station? They are just hanging around, throwing rotten tomatoes at pasing trains.
This time I remembered to attach the log, though…

record-20141224-1459.txt (1.5 MB)


Daniel, the station on the island might not be connected either, since the tunnel seems to go all the way through the island.


Oh wow, that’s a good point. Perhaps a little feedback on the circle would be helpful? Like either a circular outline of the color of the line(s) that it’s hooked up to or maybe just some tick marks?


Guess the bypassed mark should have precedence over the tunnel mark, even it then seems like two tunnels have been used.


I know this is an old one, but just encountered the same problem, thought it better to bump this one rather than duplicate(?)
The passengers on the square station weren’t being picked up at all… (197.3 KB)


Do you know which direction is your red train going? And had you tried placing a red train behind the Square, so that the red train is going towards Triangle before you lost?


It was going clockwise so, circle->square->triangle,
the blue train was going anti-clockwise, also circle->square->triangle,
and the green one clockwise, star->square->triangle

Unfortunately, by the time I realised that it wasn’t picking up passengers it was game over. I’d seen the station overcrowding and just allowed the train to get there in it’s own time, so when it failed to pick up it just went over the threshold…


The only thing I can say is that you can report it again in this thread here:

And just wait for one of the developers to address either thread. It should be on the Trello board soon.


First, I haven’t played for a long time and I have to say that I really like the Shinkansen.
But I encountered this bug again as well, there were some stations where the passengers refused to board the train. I first realized that at the middle circle station in green line, four triangles and one star just threw rotten fruit despite everything I tried.
Log attached.

record-20150713-2352.txt (1.2 MB)


I’m getting this now too, on beta 28. This has happened on a couple of games playing São Paulo. I tried dragging a few lines to the station that was having problems but the passengers stubbornly remained. It also seemed to get worse as the game progressed.


I’m getting a similar problem on version 201604151336 (gamma8) in Kairo by playing endless mode. Trains refuses to pick up passengers from all stations of the red and orange line.


Do you happen to have the game session log files? If yes, please upload them, so the developers can review what’s going on.



In Cairo I have the same with squares, if I make 2 loops on the left side (lik Eiseg, without crosssings), and then cross from 1 station to a square, the train left the island without squares regularly.


The developers would still need the session log file, in order to be useful to debug the issue though.