Ubuntu 16 / Steam: keeps on crashing


#1

Hi there,
I was an early supporter of the game and purchased it before Beta and all that. It worked like a charm on earlier versions of the game and my OS.

I just wanted to try the game again after a few years and it keeps on crashing being a few minutes or seconds into the game. Once, I was able to start a map and play for a while before it happened. It was run through Steam on Ubuntu 16.04.

The log can be found here: https://pastebin.com/uY5VXE4d
Any ideas on this?

Your help is much appreciated!
Thanks,
Jake


#2

Hi Jake,

Blargh, sorry for the hassle. Unfortunately a lot of how well the game runs on Linux is up to the Unity runtime — it makes it super easy to deploy to Linux, except when it breaks and we have no clue why and no way to fix it. Could you please try the ‘opengl2’ branch on Steam? That is the last live build that uses the older OpenGL 2.X runtime before Unity deprecated it in favour of modern OpenGL and their experimental Vulkan renderer.


#3

Hi Peter,

sure - would love to try that. Can you give me a hint how to find that branch? I looked on Steam to find different versions of the game, but couldn’t find anything.
(Apparently, I have openGL3 installed, if that helps.)

Thanks for helping me out on this - that’s really appreciated!
Jake


#4

Ah sure thing, so head to your Steam Library, right-click on Mini Metro in the left pane, click Properties. Head to the Betas tab and select ‘opengl2’ from the dropdown, click Close. It can take a while for the client to register the change so I just restart Steam to force it to download the new build. :slight_smile:


#5

Hi again,
I tried it today and so far it works like a charm! Yiiiha!
Thanks again!